• Willkommen im neuen Alpinforum!

    Das Alpinforum ist erfolgreich auf die neue Forensoftware XenForo umgezogen. Benutzerkonten und Foreninhalte wurden übernommen, sodass ihr euch wie gewohnt anmelden könnt.

    Schaut euch gerne um und probiert die neuen Funktionen aus. Solltet ihr Fehler oder Unstimmigkeiten entdecken, meldet sie bitte im entsprechenden Thema.

    Alle Informationen zur Migration und zum neuen Forum findet ihr hier:

    Zur ausführlichen Ankündigung

    Viel Spaß im neuen Alpinforum!

    Euer Alpinforum-Team

Fehler im Forum 3.0

Status
Für weitere Antworten geschlossen.
Heut am späten Vormittag war mal wieder etwas in der Datenbank kaputt. Diesmal hatte es die Posts-Tabelle erwischt. Die ist etwas aufwendiger zu reparieren, da sie größer ist als alle anderen Tabellen. Das hat sich gestern schon angekündigt, dass hier bald wieder was kommen wird (die Index-Fehler, die oben genannt wurden, sind ein Anzeichen dafür).

Nachdem die ersten Reparaturversuche meinerseits fehlgeschlagen sind, hat Ram-Brand, um Last vom Server zu nehmen, das Forum kurzzeitig "auf Eis" gelegt, so dass mehr Kapazität für die Reparatur der DB zur Verfügung stand, die dann auch erfolgreich war. Ich habe dann noch ein Backup gezogen (wenn's schonmal eine Loginsperre gibt und man das zu 'ner vernünftigen Zeit machen kann, dann dachte ich mir, die Chance gleich mal nutzen), was die Nicht-Verfügbarkeit des Forums nochmal um 20 Minuten verlängert hat.

Keine Angst - das Forum wird schon nicht sterben ;)
 
hebi schrieb:
Keine Angst - das Forum wird schon nicht sterben ;)
Aber ich fürchte, Du hast irgendwie den offensichtlich bereits gestellten Invaliditätspensionsantrag des Servers übersehen... ;D
Jedenfalls vielen Dank für Deine Mühe mit dem Biest...:!: :!: :!:
 
Ja, der Server läuft schon mit 6m/s

Und wenn dann jemand von den vielen Leuten ungeschickt einsteigt, dann muss halt auf den Not-Aus gedrückt werden.

:mrgreen:
 
Habe den Eindruck, daß seit dem Ausfall mein Beitragszähler verändert (verringert) ist. Stand zwar vorher auch "Nebelhorn", bilde mir aber ein die Anzahl war höher.
Falls ja, spinnt dann nur der Beitragszähler oder sind dann Beiträge verschwunden?
 
Ram-Brand schrieb:
Ja, der Server läuft schon mit 6m/s
Und wenn dann jemand von den vielen Leuten ungeschickt einsteigt, dann muss halt auf den Not-Aus gedrückt werden. :mrgreen:
Fixgekuppelt... :?: :rofl:
 
Falls ja, spinnt dann nur der Beitragszähler oder sind dann Beiträge verschwunden?
Vielleicht sind dies ja auch noch gewisse Nachwehen, als vor ein paar Monaten die Zähler zurückgestellt worden sind.
 
Von Änderungen in der Posts-Tabelle bleibt der Beitragszähler erstmal unbeeinflusst. phpbb führt in der User-Tabelle für jeden User einen eigenen Beitragscounter mit (wohl aus Performance-Gründen, aus DB-Design-Sicht macht das keinen Sinn). Man kann aber in der Admin-Oberfläche diesen "Beitragszähler" neu berechnen lassen, was Ram nach dem letzten größeren Ausfall im November getan hat, um die Counter der User, die rausgeflogen waren, wieder anzupassen. Ich denke, dass bei allen dabei einige Beiträge "verschwunden" sind.

Gründe könnten sein:
- Topics im Meet werden ja nach 30 tagen ohne Beiträge gelöscht. Diese Beiträge zählen beim Posten als neuer Beitrag, der Counter geht hoch. Sind die Beiträge aber gelöscht, kann sie der Beitragszählersync nicht mehr finden => der Counter geht runter
- Beiträge die in anderen Unterforen mal gelöscht wurden, konnten beim Sync natürlich auch nicht mehr gefunden werden
- Das Rateforum. Da weiss ich jetzt nicht, wie das da momentan ist - im Sommer irgendwann wurden diese Beiträge mal nicht für den Beitragszähler gezählt - ob das noch so ist und ob das Auswirkungen auf den Sync des Zähler hat, weiss nicht nicht.
 
Auch das AlpinWiki meldet:

Es gab einen Syntaxfehler in der Datenbankabfrage. Die letzte Datenbankabfrage lautete:

(SQL-Abfrage versteckt)

aus der Funktion "". MySQL meldete den Fehler "1194: Table 'searchindex' is marked as crashed and should be repaired (localhost)".
 
Ram-Brand schrieb:
Ja, der Server läuft schon mit 6m/s

Und wenn dann jemand von den vielen Leuten ungeschickt einsteigt, dann muss halt auf den Not-Aus gedrückt werden.

:mrgreen:

Kläre mich als normalen PC-Anwender doch bitte mal auf - wie kann man denn geschickt oder ungeschickt einsteigen?
 
Wenn man beim Einstieg z.B. den Ski-Stick. äh... USB-Stick verliert und beim Versuch ihn aufzuheben hin fällt.

Dann muss halt Not-Aus gedrückt werden. :)
 
Nachdem da ja offenbar in letzter Zeit vermehrt Datenverluste die Ausfallsursachen sind stellt sich die Frage ob nicht irgendeine der Serverfestplatten nen Knacks hat und dabei ist, so langsam ihr Leben auszuhauchen - das erinnert mich nämlich irgendwie an den letzten Exitus einer Platte in meinem PC...:gruebel:
 
Du willst doch nicht etwa, deinen PC mit unserem professionellen Server vergleichen!
Das wäre ja das berühmte Beispiel: "Apfel und Birnen".

Der Server ist halt zeitweilig überlastet und schaltet dann nach und nach Dinge ab, die nicht lebensnotwendig sind.
Wie ein erfrierender Bergsteiger. Er die Gliedmaßen, dann kommt der Rest dran.
So macht das der Server auch.

Und wenn das gerade bei einem Schreibzugriff auf die Datenbank passiert, das diese abgestellt wird, dann gibt es Fehler im System.
 
Ram-Brand schrieb:
Du willst doch nicht etwa deinen PC mit unserem professionellen Server vergleichen!
In dem Falle doch insoferne, daß zwischen Festplatte PC und Festplatte Server kaum große bauliche Unterschiede bestehen werden d. h. Datenverlust wär auch bei nem Server möglich und immer ein Alarmzeichen. Abgesehen davon verbaute ich immer möglichst langsame Platten und mit Zusatzlüftern um dafür höhere Lebensdauer zu erreichen; "verstorben" ist bei mir auch nicht die älteste sondern kurze Zeit nach seiner Inbetriebnahme ein später zusätzlich eingebautes wesentlich neueres Exemplar welches vermutlich von Haus aus schon ne Meise hatte.

Allerdings find ich die Serversteuerung doch insoferne etwas befremdlich weil ich eigentlich davon ausgegangen bin, daß der Server nicht laufende Schreib - bzw. Lesezugriffe auf die Datenbank unterbricht sondern nur neu angeforderte zur Überlastungsverhinderung bei Bedarf stoppen kann. Wär ja zum Vergleich dann dasselbe als wenn man in seiner Wohnung bei Gefahr einer Stromkreisüberlastung am Elektroherd nicht einfach eine der Platten etwas zurückschaltete sondern gleich die gesamte Herdsicherung rausnähme...:wink:
 
^^ Was schreibst du eigentlich für lustige Sachen... :roll: Serverfestplatten sind als RAID geschaltet, das ist was anderes als zu Hause.
 
^^ Außerdem sind Serverfestplatten anders gebaut.
z.B. die Lagerung ist für Dauerbetrieb ausgelegt.
 
br403 schrieb:
Serverfestplatten sind als RAID geschaltet, das ist was anderes als zu Hause.
Nur scheint das offensichtlich auch noch nicht ganz der Weisheit letzter Schluß zu sein...:wink:
 
Nein.

Ist alles in Arbeit.
Bis spätestens Anfang 2010 werden wir das Problem hoffentlich erfolgreich gelöst haben.

Solange am besten die Stoßzeiten 17:00 bis 22:00 Uhr meiden. :?
 
Beim Wiki stimmt auch irgendwas nicht. Beim Einbinden eines Bildes krieg ich folgende, nicht sehr erhellende Fehlermeldung:

Fehler in der Datenbank
Aus AlpinWiki
Wechseln zu: Navigation, Suche
Es gab einen Syntaxfehler in der Datenbankabfrage. Die letzte Datenbankabfrage lautete:

(SQL-Abfrage versteckt)

aus der Funktion "SearchMySQL4::update". MySQL meldete den Fehler "1034: Incorrect key file for table 'searchindex'; try to repair it (localhost)".
 
Status
Für weitere Antworten geschlossen.
Zurück
Oben